On Fri, Jun 07, 2002 at 01:30:37PM -0700, David O'Brien wrote:
> On Fri, Jun 07, 2002 at 12:59:55PM -0700, Brooks Davis wrote:
> > On Thu, Jun 06, 2002 at 04:06:40PM +1000, Bruce Evans wrote:
> > > > This fixes the panic.  It appears there's also another bug in dump
> > > > though.  When I run dump I get this:
> ...
> > > >   DUMP: master/slave protocol botched.
> > > >   DUMP: The ENTIRE dump is aborted.
> ...
> > > I guess this is another 64-bit daddr_t problem.  At least
> > > `daddr_t idblk[MAXNINDIR]' in traverse.c seems to be broken.  This seems
> > > to be fixed in the ufs2 patch.
> > 
> > Applying phk's patch seems to have fixed it.  It's a bit overkill for
> > fixing dump, but it did work and I guess this way I can do some limited
> > testing of the ufs2 patch.
> Can you reduce PHK's ufs2 patch down to the minium required to fix dump?
> That could then be committed now.

The changes to dump are rather large so I doubt I'd have much luck.
Also, it appears I spoke too soon.  I was able to dump / and /var, but
my /usr partition failed when I did another amanda run.  I'm running a
new test to /dev/null to see if I get anything useful out of it.

-- Brooks

Any statement of the form "X is the one, true Y" is FALSE.
PGP fingerprint 655D 519C 26A7 82E7 2529  9BF0 5D8E 8BE9 F238 1AD4

Attachment: msg39339/pgp00000.pgp
Description: PGP signature

Reply via email to