I know that the specific mergemaster issues have been addressed, but I
thought this experience pointed out something subtly astonishing, so I
figured I'd point it out.

I ran mergemaster, and the perl wrapper started complaining that I
needed to install perl, so I did "pkg_add -r perl".  The port talked
all about "use.perl port" or "use.perl system", but I figured
"system" was "wrapper" so I didn't bother running use.perl .  I tried
"perl -de 0", and voila, I had perl.  So I ran mergemaster again,
and the wrapper started complaining again that I needed to install

Turns out that mergemaster sets a restrictive PATH, and the wrapper
(apparently) looks for the "real" perl in the PATH.  This can be
awfully confusing -- "/usr/bin/perl" works, but "env PATH=/usr/bin perl"
doesn't work.

I ran "use.perl port", and that gave me a working perl for mergemaster.
Interestingly, "use.perl system" didn't give me back the perl wrapper;
I'm not sure what I got.  Sigh.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to