I upgraded a machine from 4.6R to -CURRENT today and had similar
problems.  Comments below.

On Wed, 14 Aug 2002, David Wolfskill wrote:
>       To upgrade from 4.x-stable to current
>       -------------------------------------
>       make buildworld
>       make buildkernel KERNCONF=YOUR_KERNEL_HERE
>       cp src/sys/${MACHINE_ARCH}/conf/GENERIC.hints /boot/device.hints [2]
>       make installkernel KERNCONF=YOUR_KERNEL_HERE
> No problem up to here.

>       reboot in single user [3]
> OK; here we have a fundamental problem, illustrated by the following
> commands I issued just after the "make installkernel":
> freebeast(4.6-S)[3] grep '^kernel' /boot/defaults/loader.conf
> kernel="/kernel"
> kernel_options=""
> freebeast(4.6-S)[4]
> The clue that I had was reviewing the transcript, and when I did the
> single-user boot, the system identified itself as 4.6-STABLE.

This happened to me too.  Perhaps the instructions should say to unload
kernel; load /boot/kernel/kernel on reboot or maybe explicitly copy in the
new /boot/defaults/loader.conf like you do with device.hints?

I didn't notice the 4.6 dmesg while booting so I went through the make
installworld using the 4.6 kernel.  It got to chpass and then failed with
a sig 11.  It turned out part of the chpass install uses chflags and I
believe the syscall changed between 4.6R and current.

I rebooted at that point since things couldn't continue in the
installworld and the new kernel's ACPI blew major chunks (endless loop).  
So I booted my stable partition, did another buildkernel/installkernel on
the -current partition and then rebooted.  ACPI paniced but I was able to
boot the new kernel by disabling ACPI (separate message on this).

After booting the -current kernel, mergemaster and installworld worked
just fine.  My system was running fine when I went home tonight.

> # sync
> # which grep
> Out of memory!
> pid 3263 (perl), uid 0: exited on signal 11 (core dumped)
> [1]   3263 Segmentation fault (core dumped) which grep
> # reboot
> I was able to perform another single-user reboot, but successive attempts
> to "make installworld" died with the "out of memory" symptom.
>       mergemaster             [4]
>       [1]
>       <reboot>
> I wasn't able to get as far as completing the "make installworld" -- I tried
> with -k once; that didn't seem to help, either.
> So -- at some point I think this needs to be figured out.
> I'll be happy to poke around and test.

I didn't get any out of memory errors, just repeatable sig 11 when running


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to