Python 2.7 will have no upstream support after 2020, and right now it no more getting new features. So I'd want to start poisoning^W introducing python3 into user system via ports tree and here is what I suggest to start to do right now:

- if port has a build dependency upon python and it can be built both with python2 and python3, force it to build with python3 - if some standalone application can be running both with python2 and python3 and it have equivalent python3 dependencies, force it to be run with python3

We also need to explicitly mark python2-only ports to simplify switching to python3 as default at some point of time.

What you guys think about? If there is general consensus, we may enforce this via Porters Handbook.


T.O.S. Of Reality
freebsd-python@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-python-unsubscr...@freebsd.org"

Reply via email to