On 2016-10-17 12:35, Ruslan Makhmatkhanov wrote:

What I actually meant is to utilize USES=python:3.3+ for such ports,
to make it pick up default python3 version.

Yeah I "misunderstood you correctly", heh, sorry I wanted to say two different things at once....

The only problem with that (and btw, please let's use 3.4+ because 3.3 is badly supported even upstream) is ports that are dependencies to python:2 ports. So those would have to be identified, which is the idea behind my continuous poudriere run.

IMHO variants are the only thing that would help us force all that can go py3 to go py3, and build py2 in support for rdeps that require 2. Because right now it's a bit of a mess when you have such conflicting requirements.


Vlad K.
freebsd-python@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-python-unsubscr...@freebsd.org"

Reply via email to