On 1/3/2003 at 9:25 AM MikeM wrote:

| [snip]
|To you and others who have helped me, here's what I'm doing.
|- tomorrow I am upgrading from 4.5 to 4.7
|- once that proves stable, I'll increase the DIRHASH value appropriately.
|- once that proves stable, I'll "tunefs -n enable /usr" to turn on soft
|I'll report back with my experiences with the new configuration so that
|archive remains complete.

The upgrade to 4.7 went very smoothly.  Many thanks to the documentation
team for the excellent documentation on upgrading
(http://www.freebsd.org/releases/4.7R/relnotes-i386.html#AEN577).  This was
my first major upgrade on a remote server (I have been keeping up-to-date
with the security patches).  Needless to say, I was a bit apprehensive when
I typed that "reboot" command.  I never thought I'd be so very happy to see
the words 

        "Copyright (c) 1980, 1983, 1986, 1988, 1990, 1991, 1993, 1994
       The Regents of the University of California.  All rights reserved.
         FreeBSD 4.7-RELEASE-p2 ..."

appear on my ssh screen.  :-)

Next I did the tunefs step.   I had to ask the techs at the datacenter to
boot into single user mode and perform the tunefs on the local console.
That also went smoothly.

When I tried to  "tar -yxf" the freedb archive, the server became
unresponsive.  I am not sure exactly what the root cause of the problem
was, as my ssh session went dead and I could not re-establish a connection.
 Long story short, I found out the tech support in the data center
(www.tera-byte.com) is excellent.   The tech re-established the local
console and ran the fsck required to bring the server back to life.  He did
mention the following in one of his emails, "[the server] appears to be
having some problems with the fsck due to some dirty inodes... ".

The server is back online now, and running well.  Trying to duplicate the
problem, I ran a similar sequence sequence of events on a server here at my
house.   It didn't crash, but I did get screenfuls of the following error

   /usr: create/symlink failed, no inodes free
   tar: misc/ed11d70f: Cannot open: No space left on device

That message was repeated for each of the hundreds of thousands of files.
I suspect 'something' on my remote server was not happy about dealing with
such a flood of error messages.

At this point, I'm not willing to newfs the file system to get the number
of inodes that I need.  So I think, so far as I am concerned, this
experiment is over.  :-)

Once again, thanks to everyone who gave me help on this.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to