Hi Bill,

I'm not seeing this.  I tried this with PuTTY 0.58 on a fresh FreeBSD 6.2p1
system and had no problems.  So I grabbed the latest PuTTY 0.59, and that
worked fine as well.


I haven't been following this thread, so I don't have any ideas on what
your problem might be, but it's certainly not FreeBSD or puTTY's fault
or I'd be seeing the same problem.

The issue is that PuTTY does not fall back from its SSH2 attempt to SSH1 (with password authentication), as is what I specified in my /etc/ssh/sshd_config

Is this what you tried too, or did you use SSH2 (i.e. key authentication, instead of password authentication)?

In my case, SSHD is running in debug mode and the debug log clearly indicates that PuTTY only tries SSH2 and does not fall back to SSH1, whereas on my live box (FreeBSD 5.4 release AMD64, custom kernel), PuTTY does fall back to SSH1.

The 'lines' to the new server are about as short as they can be, as I'm currently setting the machine up over our local network, so the only thing in between the client and server is our router, which does not mess with the SSH traffic...

In short: I see no reason why the PuTTY / FreeBSD 6.2 SSH combination would _not_ be at fault (especially as other SSH clients do work fine on this box, and as PuTTY also works when connecting to other boxes). :P Contrary to what I was thinking yesterday, I don't think my configuration is at fault...

In case in such a situation the password authentication does work fine for you, I'd be curious to find out the reason why it doesn't work for me (perhaps you could then also post me your sshd_config settings).

As mentioned, there is an easy work around by using a different SSH client, but PuTTY is handy for quick d/l-ing when abroad, and not having administrator's rights to the machine you're on at that time.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to