On Jan 9, 2008 1:38 PM, Schiz0 <[EMAIL PROTECTED]> wrote:
> Hey,
>
> I recently upgraded from 6.3-PRERELEASE to 7.0-PRERELEASE. I had some
> problem with the ports, but I got that taken care of.
>
> Now I'm having another very odd problem.
>
> I originally noticed something odd when I tried to shutdown from
> multiuser mode into single user mode. I ran "shutdown now" as root in
> multiuser. It said it was shutting down, etc. But then, it gave me the
> normal multiuser login prompt. So then I tried rebooting completely,
> and that's where the big error came up:
>
> -----------------------------------------------------
> FreeBSD/i386 bootstrap loader, Revision 1.1
> ([EMAIL PROTECTED], Tue Jan 8 14:22:21 EST 2008)
> > \
> \: unknown command
> -
> /boot/kernel/kernel text=0x29e868 data=0x2db8c+0x23814
> syms=[0x4+0x34c10+0x4+0x43ef1]
> Hit [Enter] to boot immediately, or any other key for a command prompt.
> Booting [/boot/kernel/kernel] in 4 seconds ...
> -----------------------------------------------------
>
> Why it trying to run the command "\" ? Right before I did this, I
> rebuilt world, including the kernel. I installed the new kernel, and
> was moving down to single user to install world.
>
> Is my bootloader corrupt somehow?
>
> Thanks.
>

I'm still having this problem. I installed from the 7.0-RC1 Boot Only
iso. It worked fine. I csuped RELENG_7 and built world, and now it's
giving me the same error.

There's nothign weird in /etc/fstab. I didn't change any files in
/boot. I put the 7.0-RC1 CD in the drive, and diff'ed the /boot from
MY system and the /boot from the CD. Nothing was different. I ran diff
on the loader.conf, loader.rc, and all the .4th files.

Note, I can still boot up fine. I just hit enter at that error prompt
and it boots ok.

Now, I'm even in a bigger hole. My power died this weekend, and I
guess the / partition has some errors on it, so it is being mounted
read-only. But I'm unable to get into single user mode. I tried
"shutdown now" and "init 1" and they both brought me back to the
multi-user login prompt. And there's no menu to reboot and select
single user mode from.

Can someone help me either solve the bootloader problem, or just how
to get into single user mode?

Thanks.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to