On Thu, Feb 13, 2003 at 03:33:57PM -0500, Bill Moran wrote:
> northern snowfall wrote:
> >>  (which rules out DNS problems). 
> >
> >Not unless he does "ping -n". If not, the A will still attempt
> >to be resolved.
> >Don
> Good point, I stand corrected.
> -- 
> Bill Moran

I must be missing something.  Don is right, the manpage clearly states
that the -n option sould supress symbolic name lookups, but no matter
how hard I try I cannot elicit a DNS query out of ping.  I run named on
my local network.  First, I pinged an IP address that I knew my system
would not have cached anywhere - no DNS lookup.  Then I disabled named
and tried again with a few new IP addresses - still no DNS queries.
Then I even went so far as to rename my hosts file.  At this point I
couldn't even ping 'localhost' by name.  Each time, the ping worked fine
and never once issued a DNS query - I was watching with ethereal.  Is
the manpage incorrect?

Further, the OP's gateway machine should have no effect whatsoever on his
ability to ping another machine directly connected to his switch.  This
problem is mighty strange.


GPG Public Key ID: 0x4250A04C
gpg --keyserver pgp.mit.edu --recv-keys 4250A04C

Attachment: msg19341/pgp00000.pgp
Description: PGP signature

Reply via email to