On Mon, 24 Feb 2003 18:39:11 +1100
Sam Izzo <[EMAIL PROTECTED]> wrote:


> Yeah, OpenPTC doesn't accept that parameter :/

Being a curious person myself I cvs co'd the OpenPTC thing to try it
here. I've tried it on a NetBSD box, but the procedure to build it on
FreeBSD should be similar.

First I had to patch configure. This is my patch (change /usr/pkg/lib to
/usr/local/lib on FreeBSD)

--- configure.orig      2003-02-24 09:30:02.000000000 +0100
+++ configure   2003-02-24 09:33:45.000000000 +0100
@@ -1946,7 +1946,7 @@
 #include "confdefs.h"
 #include <$ac_hdr>
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ac_try="$ac_cpp -I/usr/pkg/include conftest.$ac_ext >/dev/null
 { (eval echo configure:1951: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
 ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
 if test -z "$ac_err"; then

Then I used this:

$ env CFLAGS="-I/usr/pkg/include" LDFLAGS="-L/usr/pkg/lib" ./configure

(Again, change /usr/pkg to /usr/local for FreeBSD)

configure went okay. I still get an error while trying to build the lib,
but it's a step.

I'll post in a while if I get it to build, right now I have to get onto
other things. Hope this helps a bit. Perhaps it would be worth e-mailing
the developers and making an offer to help them make a more sane
configure script.

        Miguel Mendez - [EMAIL PROTECTED]
        GPG Public Key :: http://energyhq.homeip.net/files/pubkey.txt
        EnergyHQ :: http://www.energyhq.tk
        Of course it runs NetBSD!
        Tired of Spam? -> http://www.trustic.com

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to