On Sun, 2003-02-23 at 07:27, questions-digest wrote:

> Date: Sat, 22 Feb 2003 14:11:01 +0100
> From: Cliff Sarginson <[EMAIL PROTECTED]>
> Subject: Re: LAN and sound support in ASUS A7V333-X
> 
> On Tue, Feb 18, 2003 at 12:21:10PM -0500, Lowell Gilbert wrote:
> > Mats Dufberg <[EMAIL PROTECTED]> writes:
> > 
> > > I run FreeBSD 5.0-RELEASE on a ASUS A7V333-X motherboard. On the card
> > > there is both LAN and sound card built in, but neither is detected by
> > > FreeBSD. Does anyone have any information if it is possible to get that
> > > support?
> > 
> > I'm not running 5.0, so I may not have the details exactly right, but
> > I think they're similar to 4.x.  You'll need to load the pcm module or
> > compile it into your kernel.
> > 
> > The ethernet card I'm not sure about, though; I don't know which
> > driver is supposed to handle that one.
> > 
> I think you may not have much success with the Ethernet card, I didn't
> with both FreeBSD and Linux on a machine with the same motherboard.
> A search of the maker's site proved fruitless. I would love to know if
> it is possible though, since eventually said machine will need 2 NICS.
> 
> I have not tried the sound, since the machine in question is not
> destined for music :)
> 
> - -- 
> Regards
>    Cliff Sarginson 
>    The Netherlands
> 
> [ This mail has been checked as virus-free ]
Hi,

I have the later version of the ASUS MB (A7V8X) with onboard Realtek
audio and Broadcom NIC. While not directly applicable, you might find
that my experiences are useful for making your h/w operate.

The issues that I had were that loading drivers for other devices
blocked access to the h/w for the correct drivers.

To get both devices working I've done the following:
1. build a new kernel conf file in which I disabled any NIC that was not
in my system (if you have a miibus based card such as my broadcom,
ensure that you leave the line: 'device miibus' uncommented.

2. disbled all the soundcards that were not in my system. Note that many
newer sound cards only need the pcm driver including the Realtek device
on my m/b.

3. rebuilt the new kernel (check the handbook for details) and checked
to see if it shows up in the boot messages (dmesg | more).

4. if 3, configure the ethernet card using ifconfig, and check out the
basic 'using sound on freebsd' article on www.onlamp.com in the bsd
section.

5. if not 3, you might check to see that you have the correct device
nodes in your /dev directory for the soundcard (assuming you're running
under Freebsd 4x and not 5). For me these are /dev/audio*

if you still can't get it to work, email me directly and we'll see if we
can work though it.

regards,
Charles



To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to