Warren Block wrote:
On Mon, 20 Apr 2009, Ivan "Rambius" Ivanov wrote:

I even tried with Manolis's xorg.conf - same results.

I use startx as a non-root user and I invoke startkde from .xinitrc,
but kde does not appear. The screen just blinks once or twice. I also
tried to enable xdm from /etc/ttys - same result.

Indeed, I think the xorg.conf is OK and no errors appear in the log,
but still I can not get it running.

It's easier to test if you remove the big desktop manager from the equation. So rename or delete your .xinitrc, .xsession, and don't start X from /etc/ttys. Don't forget to kill -HUP 1 and kill xdm.
Then try startx to just get the plain twm screen.

I'm having similar problems after upgrading an older machine to Xorg 7.4. The monitor blinks it's power light indicating no signal.

While CTRL+ALT+Backspace does not kill the X server, I can press CTRL+ALT+F1 or ALT+F1 to return to the text mode console. I then kill the X server via CTRL+C.

Interestingly, if I restart the server (via Xorg, X, startx, etc), the screen will switch to graphics mode and briefly show the contents of the previous session, and then go blank. I believe I'm seeing the contents of the video memory after the mode switch and before the video memory is overwritten or erased.

I believe that Xorg is working fine, but somehow the video card is told to blank the screen (maybe via DPMS?) or is otherwise incorrectly programmed.

I was using the DPMS screen saver modul via rc.conf, I will remove that and check again.

I'll also remove all the .xinitrc, .xsession, left over crud as well.

This is a machine using the VESA driver with an older Voodoo Banshee AGP card.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to