"fbsd_user" <[EMAIL PROTECTED]> writes:

> I have a USR sportster 14.4 external serial modem which works fine
> under FBSD 4.8.
> Dip switches 3-7-8 are set to 'on' which is down, all others are set
> to off which is up.
> 3 = display result codes
> 7 = load factory defaults
> 8 = smart mode

Which my 14.4 internal's manual recommends for software flow control
(which is recommended only if the cable doesn't support hardware
handshaking which almost all cables do support).  Except it recommends
switch 5 be on/down too.  It doesn't bother to describe the switches,
but my other manual says it's for "auto answer" so it's position
shouldn't matter for this problem.  Of course, my internal modem has
no switches at all, so it can't help with the internal modem problem.

FreeBSD surely should support hardware flow control (it's in "stty"),
but I guess I can try an XON/XOFF configuration; I don't have a
distinct memory of trying that on the external modem.

> Modem has to be powered on before you boot FBSD box modem is cabled
> to. 

Now, THAT could be my problem in the case of the external modem.  I
thought the drivers were smarter than that; rebooting is nasty, when
serial lines are hot-pluggable.  I'll try the external modem again.

> again. Can you run mswindows on the pc to verify serial port and
> modem work.

I've no mswindows to run, but I've tried three different serial ports
on the motherboard and ISA card.  I've probably tried the other things
you suggested; I hoped there would be some hints about software
configuration that I had missed.  But I can do more experiments with
other modems and other computers and Linux to determine whether the
problem is in the hardware or software.

Thanks for the hints.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to