On Tuesday, 14 October 2003 at 22:45:02 -0700, aarong wrote:
> On Tuesday, October 14, 2003, at 10:04  PM, Greg 'groggy' Lehey wrote:
>> I'm going to need more information on this.  It doesn't correspond at
>> all with my experience.  Here's an example:
>> ...
> I found my problem, I would obliterate a configuration and not
> saveconfig.

No, that's not only not necessary, it doesn't work.  saveconfig saves,
well, configurations.  resetconfig obliterates configurations, so
there's nothing left to save.

> It is my experience that resetconfig will obliterate only the
> configuration currently read into memory, and NOT clear the Vinum
> configuration written to Vinum disks - in my case da0 and da1.

As I showed in the example, you don't need a saveconfig.

> On another box, again 4.8-RELEASE only with IDE instead of SCSI
> drives, I completed setup and began to mirror. Without thinking I
> tried to add plexes on an uninitialized drive and as such, Vinum
> read the new device name beta, but listed the drive in a state of
> referenced. I initialized the drive per Handbook instructions,
> copied the disklabel from ad0 to ad3 (drive beta) and tried
> again. After successfully starting each new plex, I saved the
> config, double checked the config written to both disks with
> dumpconfig, and rebooted. Upon reboot I was back to square one. I've
> replicated this three times now. Did you know it takes 2 hours two
> completely mirror a 69GB slice across two IDE drives? ;-)
> What I find VERY interesting is that ad3, hence known to vinum as
> "beta", has the correct dumpconfig output: all plexes are "state up"
> and everything is kosher. Drive "alpha", aka ad0, has the incorrect
> original config where I accidently tried to create plexes on an
> uninitialized drive. All *.p1 plexes are "state faulty" on "alpha" and
> all the saveconfig's in the world don't seem to be changing this. I, of
> course, have diligently searched the mailing lists looking for anyone
> with a similar problem, only to find another guy who didn't initialize
> the second drive correctly but then promptly fixed it.

I'm getting confused here.  A bit of the output of vinum(8) would go a
long way.  What does 'vinum list' say?

>>> 2) why doesn't dd if=/dev/zero of=/dev/da0 seek=16 count=265 work?
>>> What's in those 265 sectors that I can't touch?
>> The second sector on the disk is protected.  You can't write to it.
>> If you start at sector 2, it will work.
>> The Vinum label is at sector 8.  That's the only sector you need to
>> clear to manually obliterate a Vinum configuration.

> Then the command should look something like: dd if=/dev/zero
> of=/dev/da0 seek=18 count=263 ?  


> Sector eight after the sixteen sector bootstrap, correct?

No.  Just sector 8:

   dd if=/dev/zero of=/dev/da0 seek=8 count=1

But you shouldn't need that.

When replying to this message, please copy the original recipients.
If you don't, I may ignore the reply or reply to the original recipients.
For more information, see http://www.lemis.com/questions.html
See complete headers for address and phone numbers.

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to