On Jan 22, 2004, at 5:24 PM, Keith Kelly wrote:
I already tried (with both 4.9 and 5.1) letting the FreeBSD install proceed
with fdisk's geometry value assumptions, and what I always get is a
non-bootable hard drive that gives the "Missing operating system" error at
boot.

Sufficiently old motherboards and BIOS versions don't understand the LBA addressing mode used by modern drives, and are limited to seeing approx 8.4 GB using the classic C/H/S values. See whether the BIOS lets you configure the drive to LBA mode rather than "automatic", "C/H/S", or "extended C/H/S" mode. If it doesn't, check to see whether there is a BIOS update available for your hardware.


It may be the case that this doesn't resolve the issue. You can try to create a small (say 32MB) DOS partition using classic MS-DOS 6.x or a utility from the drive manufacturer, and verify whether you can boot into that. If you can't and still get the "missing OS" error, you've got hardware issues and should consider replacing your MB. If you can boot to a DOS partition on the hard disk, then try installing FreeBSD to the remaining space, leaving the DOS partition intact. This will give you a better shot of using a geometry that your BIOS is able to boot.

[ The only hardware I've seen which required that kind of thing was a no-name P133 grade machine... ]

--
-Chuck

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to