Mike Jeays wrote:

On Tue, 2004-05-18 at 04:09, Ben Paley wrote:

On Tuesday 18 May 2004 04:02, Mike Jeays wrote:

On Mon, 2004-05-17 at 19:16, Jason Taylor wrote:

I have a similar situation with a Cannon Powershot A40.  I can't mount
it, but gphoto is able to access it.  I had to modify a config file or
two in order for the ugen devices to be created writable by anyone other
than root.  Sorry, I don't have access to that box at the moment or I'd
offer something a bit more concrete.

gphoto2 turns out to work fine, thanks very much! I wonder why Digikam doesn't work, then?

I have a Canon Powershot A70, and the same problem.  I bought a SanDisk
card reader, and it works perfectly with a Compact Flash card that has
been used in the A70.  It can be mounted as
mount -t msdos /dev/da0s1 /mnt

This may turn out to be the easiest thing in the long run: certainly my wife and kids aren't going to want to learn a CLI for getting at their snaps. I guess it's either a) buy a cardreader, b) get Digikam to work or c) something else I don't know about yet.

Thanks for both your help,

My trivial shell-script called "getphotos" does what I need, with the
appropriate entry in /etc/fstab, of course.  If you called it from a
desktop icon, it should meet the "wife and even quite young kids"
standard - with absolutely no disrespect intended to your wife and/or
kids!  And I am quite sure several people will point out how to simplify
the script.

mount /flash
find /flash/dcim -name "*.jpg" >/tmp/photos.txt
x1=`cat /tmp/photos.txt`
for f in  $x1
  cp $x1 ~/pics/Raw/
cd ~/pics/Raw
chown mike *
chmod -x *
umount /flash

gtkam is a GUI front-end for gphoto. I added an entry to /etc/usb.conf to launch gtkam when the camera is connected. Honestly, I've only tried it once since setting it all up, but it worked wonderfully that one time.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to