Kent Stewart wrote:

On Tuesday 29 June 2004 11:02 am, Bill Moran wrote:

I'm having some really weird problems with ftp performance on FreeBSD
4.10 that I just can't seem to figure out.

My uplink here maxes out at about 35k/sec.  If I scp to the machine
in question I get about 30k/sec (which is expected) but when I ftp, I
never get anything better than 15k/sec, and occasionally as low as

Using a server colocated at another facility, I can ftp at about
45k/sec, and scp at about 60k/sec.

Downloads are all as expected ... scp and ftp downloads seem to be in
about the same range, and it's a number I would expect.

I tried running the ftp daemon that ships with FreeBSD, as well as
Proftpd and they both exhibit the same performance issues.

Most settings on this machine are at their defaults.  I've tried
tweaking send/recv sizes, as well as toggling delayed_ack.  None of
these have made any difference so far.

Suggestions? Is anyone else seeing this?

I want to add that I have a machine that did that once in awhile. As soon as I see it, I look at my switch and the NIC has switched into half-duplex. An ifconfig still shows full-duplex. I would power down and reboot and it went away for awhile.

After having done this 3 or 4 times, I powered it down, reseated the NIC and it has been a little over three weeks since it flipped modes on me.


But even if it is an 10 MBit NIC running half duplex, it should still be capable of handling internet traffic at normal speeds (200 - 300 KB/s or something, depends on your line of course)

My first insight of those problems is probably bad DNS settings. What about FTPing to your ip address? Is that giving you the bad speed as well?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to