We have a custom Cypress FX2 based data acquisition card connected to a FreeBSD 
9.2 system. 

Today the device disconnected
Oct  9 03:24:11 juskym kernel: ugsio0: at uhub3, port 1, addr 3 (disconnected)

and then some time later we noticed the data acquisition process was stuck in 
'USB config SX lock' (and un-killable). I ran usbconfig and it also got stuck 
in the same wchan.

I tried rebooting it and got stuck with this on the screen..
usbus0: Controller shutdown complete
usbus1: Controller shutdown 

I have previously run the same hardware on 9.0 (where there was a panic in 
devfs triggered if the DAQ card disconncted sometimes) and 9.1 (where I have 
not seen any problems).

Does anyone have an idea about how I could go about gathering more information 
if it happens again?


Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

Reply via email to