On 10/09/13 12:04, Daniel O'Connor wrote:
Hi,
We have a custom Cypress FX2 based data acquisition card connected to a FreeBSD 
9.2 system.

Today the device disconnected
Oct  9 03:24:11 juskym kernel: ugsio0: at uhub3, port 1, addr 3 (disconnected)

and then some time later we noticed the data acquisition process was stuck in 
'USB config SX lock' (and un-killable). I ran usbconfig and it also got stuck 
in the same wchan.

I tried rebooting it and got stuck with this on the screen..
usbus0: Controller shutdown complete
usbus1: Controller shutdown

I have previously run the same hardware on 9.0 (where there was a panic in 
devfs triggered if the DAQ card disconncted sometimes) and 9.1 (where I have 
not seen any problems).

Does anyone have an idea about how I could go about gathering more information 
if it happens again?


Hi,

It is not a deadlock. It is just that the reference in /dev/cuaUX does not go away. Have you tried 9-stable? There are also some sysctls you can set, see hw.usb to change the shutdown behaviour.

--HPS

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to