http://www.freebsd.org/cgi/query-pr.cgi?pr=172955

Johann

On Monday 22 October 2012 19:19:43 Adrian Chadd wrote:
> Yay, bug!
> 
> 
> 
> Adrian
> 
> On 22 October 2012 07:21, Adrian Chadd <adr...@freebsd.org> wrote:
> > .. please file a bug. :-) Now that I have VIMAGE mostly working with
> > wifi, I'd like to take the opportunity to fix whatever 11n ibss bugs
> > you see.
> > 
> > There's no reason why aggregation and MCS rates shouldn't work with
> > IBSS. The only questionable issue right now is encryption and that
> > requires some stack/driver changes to fully support. (Read: You can't
> > do 11n + WEP by default (no, don't ask me to make it work with ath(4),
> > I won't :-)) and getting the CCMP encryption working in IBSS mode
> > requires changes to the crypto key and keycache programming.
> > 
> > 
> > 
> > Adrian
> > 
> > On 18 October 2012 00:52, Adrian Chadd <adr...@freebsd.org> wrote:
> >> Ah, it looks like the MCS rate stuff isn't being setup or negotiated
> >> right?
> >> 
> >> Please file a bug. I'm not sure if I'll have time to dig into it
> >> though; but it should be easy to fix.
> >> 
> >> 
> >> 
> >> adrian
> >> 
> >> On 18 October 2012 00:48, Johann Hugo <jh...@meraka.csir.co.za> wrote:
> >>> On Thursday 18 October 2012 09:37:09 Adrian Chadd wrote:
> >>>> Hi,
> >>>> 
> >>>> 
> >>>> 
> >>>> Try disabling ampdu - ifconfig wlanX -ampdu
> >>> 
> >>> Nope, still the same. (done on both sides)
> >>> 
> >>> 
> >>> 
> >>> mesh-1d04:~ # ifconfig wlan1 -ampdu
> >>> 
> >>> mesh-1d04:~ # ifconfig wlan1
> >>> 
> >>> wlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu
> >>> 1500
> >>> 
> >>> ether 00:0c:42:6c:61:91
> >>> 
> >>> inet 10.50.50.1 netmask 0xffffff00 broadcast 10.50.50.255
> >>> 
> >>> inet6 fe80::20c:42ff:fe6c:6191%wlan1 prefixlen 64 scopeid 0x8
> >>> 
> >>> inet6 fde4:7b85:9218:10:20c:42ff:fe6c:6191 prefixlen 64
> >>> 
> >>> nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
> >>> 
> >>> media: IEEE 802.11 Wireless Ethernet autoselect mode 11na <adhoc>
> >>> 
> >>> status: running
> >>> 
> >>> ssid testADHOC channel 28 (5140 MHz 11a ht/40-) bssid 02:8c:ca:fe:ca:10
> >>> 
> >>> regdomain NONE country ZA ecm authmode OPEN privacy OFF txpower 17
> >>> 
> >>> mcastrate 6 mgmtrate 6 scanvalid 60 -ampdu ampdulimit 8k
> >>> 
> >>> ampdudensity 8 shortgi wme burst
> >>> 
> >>> 
> >>> 
> >>> mesh-1d04:~ # ifconfig wlan1 list sta
> >>> 
> >>> ADDR AID CHAN RATE RSSI IDLE TXSEQ RXSEQ CAPS FLAG
> >>> 
> >>> 00:0c:42:6c:61:91 0 28 0M 18.5 30 25 0 I A
> >>> 
> >>> 00:0c:42:6c:63:20 0 28 54M 18.5 0 3 288 I AQ HTCAP WME
> >>> 
> >>> 
> >>> 
> >>> mesh-1d04:~ # iperf -c 10.50.50.2
> >>> 
> >>> ------------------------------------------------------------
> >>> 
> >>> Client connecting to 10.50.50.2, TCP port 5001
> >>> 
> >>> TCP window size: 32.5 KByte (default)
> >>> 
> >>> ------------------------------------------------------------
> >>> 
> >>> [ 3] local 10.50.50.1 port 61073 connected with 10.50.50.2 port 5001
> >>> 
> >>> [ ID] Interval Transfer Bandwidth
> >>> 
> >>> [ 3] 0.0-10.1 sec 24.5 MBytes 20.4 Mbits/sec
> >>> 
> >>> mesh-1d04:~ # ifconfig wlan1 list sta
> >>> 
> >>> ADDR AID CHAN RATE RSSI IDLE TXSEQ RXSEQ CAPS FLAG
> >>> 
> >>> 00:0c:42:6c:61:91 0 28 0M 18.5 0 43 656 I A
> >>> 
> >>> 00:0c:42:6c:63:20 0 28 54M 18.0 0 17776 59552 I AQ HTCAP WME
> >>> 
> >>> mesh-1d04:~ # athratestats -i ath1 -m 00:0c:42:6c:63:20
> >>> 
> >>> static_rix (-1) ratemask 0x0
> >>> 
> >>> [ 250] cur rate 54 Mb since switch: packets 4 ticks 292459
> >>> 
> >>> [ 250] last sample (6 Mb) cur sample (0 ) packets sent 28
> >>> 
> >>> [ 250] packets since sample 6 sample tt 0
> >>> 
> >>> 
> >>> 
> >>> [1600] cur rate 54 Mb since switch: packets 1 ticks 292477
> >>> 
> >>> [1600] last sample (36 Mb) cur sample (0 ) packets sent 17748
> >>> 
> >>> [1600] packets since sample 20 sample tt 764
> >>> 
> >>> 
> >>> 
> >>> TX Rate TXTOTAL:TXOK EWMA T/ F avg last xmit
> >>> 
> >>> [ 9 Mb:1600] 1:1 (100.0%) 1/ 0 1848uS 291850
> >>> 
> >>> [18 Mb:1600] 17:17 (100.0%) 19/ 0 1193uS 292315
> >>> 
> >>> [24 Mb:1600] 28:28 (100.0%) 30/ 0 956uS 292259
> >>> 
> >>> [36 Mb: 250] 1:1 (100.0%) 1/ 0 464uS 288917
> >>> 
> >>> [36 Mb:1600] 203:203 (100.0%) 214/ 0 1003uS 292325
> >>> 
> >>> [48 Mb:1600] 7733:7733 (100.0%) 8335/ 0 794uS 292323
> >>> 
> >>> [54 Mb: 250] 27:27 (100.0%) 27/ 0 444uS 292478
> >>> 
> >>> [54 Mb:1600] 9767:9767 (100.0%) 10518/ 0 648uS 292477
> >>> 
> >>>> Adrian
> >>>> 
> >>>> On 18 October 2012 00:34, Johann Hugo <jh...@meraka.csir.co.za> wrote:
> >>>> > Hi
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > Finally got a 11n test setup running FreeBSD 10.0-CURRENT on two ARM
> >>>> > 
> >>>> > boards.
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > HW = gateworks ARM
> >>>> > 
> >>>> > OS = FreeBSD 10.0-CURRENT
> >>>> > 
> >>>> > Build = arm-10-20121011
> >>>> > 
> >>>> > Wifi = RouterBOARD R52nM = AR9220
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > 11n works if one device is in AP mode and the other in ST mode, but
> >>>> > I can
> >>>> > 
> >>>> > get it running with both devices in ADHOC mode.
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > Is there a special switch or something that I need to toggle for 11n
> >>>> > to
> >>>> > 
> >>>> > work in ADHOC mode ?
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > Johann
> >>>> > 
> >>>> > 
> >>>> > 
> >>>> > _______________________________________________
> >>>> > 
> >>>> > freebsd-wireless@freebsd.org mailing list
> >>>> > 
> >>>> > http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
> >>>> > 
> >>>> > To unsubscribe, send any mail to
> >>>> > 
> >>>> > "freebsd-wireless-unsubscr...@freebsd.org"
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to