Hi Lev (and others);

I've fixed the UDP TX + rekey session drop bug.

Please re-test your testcase on the latest -HEAD and let me know how it goes.

I'd really like to sneak in these power save and reassociate changes
of mine, but first I want to make sure that your issue is correctly
resolved.

Thanks!



Adrian

On 3 May 2013 22:09, Adrian Chadd <adr...@freebsd.org> wrote:
> Hi,
>
> So doing this testing as a station doing the UDP transmitting (to a
> FreeBSD AP) is showing some interesting behaviour. No, i don't think
> it's your bug.
>
> The key re-negotiation seems to be failing somewhere; I bet it's out
> of sequence or out of order crypto frames. I've seen this happen
> before but I only fixed it for the AP case (by overriding the QOS for
> said frames so it appeared in a different TID, thus different sequence
> number space.) Since it's reauthing, it's transitioning the node
> through disassociate / re-auth / re-associate, but the current code in
> -HEAD isn't resetting the local state (aggregation, BAR state,
> filtered frames state, etc.) So things can and do go weird.
>
> I'll do some further digging into this and see if I can resolve it. I
> thought I had fixed it but .. well, obviously not. Once I have
> resolved this rekey / disconnect issue I'll keep testing things out
> and see if I've fixed your issue.
>
> (And I'll do some testing in parallel in open mode, so I don't bite this bug.)
>
>
>
> adrian
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to