On 2014/01/12 14:36, Erich Dollansky wrote:

On Fri, 10 Jan 2014 21:45:59 -0800
Adrian Chadd <adr...@freebsd.org> wrote:

Please help dig up which change broke it. Even just test out the head
iwn code from 6 months ago.
I came to a very strange result. I have iwn in the kernel since June
2012 using 10. I also have had run in the kernel of another machine
since February 2011. I could not even add runfw to the kernel those
days running some 8 stable. I kept it that way until now.

This issue was solved by gonzo in r252064.

run was always working. iwn gave problems starting between August and
November of last year on my access point but still worked on other
places. I used iwn to connect successfully to another wireless network
mid November 2013.

After adding the firmware to the kernel for both iwn and run, I could
compile the kernel and iwn started to work. runfw did not break

I wonder now if the iwn or run could even work without firmware or if
the firmware was automatically loaded even when iwn or run where
compiled into the kernel.

run(4) requires a firmware to function.  The firmware is automatically
loaded if and only if you compile runfw(4) as module and run(4)
compiled into the kernel.


freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to