Hi!

This is just an iwn panic. Did your actual -HEAD kernel panic?

Try doing this with sysctl dev.iwn.0.debug=0xff; let's see what
happens just before the firmware loses its mind.

Thanks!


-a


On 5 September 2014 12:22, Oliver Pinter <oliver.p...@gmail.com> wrote:
> I got the attached iwn panic, even if running in -ht mode. In between
> I have a working connection.
> I set up now a serial console and try to enable the ht mode with debugging.
>
> On 9/3/14, Oliver Pinter <oliver.p...@gmail.com> wrote:
>> Or not, I forgot  the -ht option in rc.conf.
>>
>> G STA + G AP = ok
>> G STA + N AP = ok
>> N STA + N AP = fail
>>
>> On 9/3/14, Oliver Pinter <oliver.p...@gmail.com> wrote:
>>> Hi!
>>>
>>> Small status update:
>>> The mode N works too, I mistyped the other AP's passwork.
>>> So both mode G and mode N working after the backports.
>>>
>>> BTW, can you MFC the same changes to 10.1?
>>>
>>> On 9/2/14, Adrian Chadd <adr...@freebsd.org> wrote:
>>>> Hi,
>>>>
>>>> Compile it with IWN_DEBUG, then
>>>>
>>>> sysctl dev.iwn.0.debug=0x1
>>>>
>>>>
>>>> -a
>>>>
>>>>
>>>> On 2 September 2014 12:41, Oliver Pinter <oliver.p...@gmail.com> wrote:
>>>>> I not tried freebsd-head yet, but I'm able today. In mode N seems like
>>>>> the NIC sends only one frame, and no more.
>>>>>
>>>>> With tcpdump and/or wlandebug I see only rx packets and no tx.
>>>>>
>>>>> If you add some pointer what changes must I create to easier debug, or
>>>>> what concrete information required, feel free to ping me or send the
>>>>> details.
>>>>>
>>>>> On 9/2/14, Adrian Chadd <adr...@freebsd.org> wrote:
>>>>>> Cool! Have you tried freebsd-head? Does it work there?
>>>>>>
>>>>>> How's it failing in association state? What's it saying?
>>>>>>
>>>>>>
>>>>>> -a
>>>>>>
>>>>>>
>>>>>> On 2 September 2014 12:30, Oliver Pinter <oliver.p...@gmail.com>
>>>>>> wrote:
>>>>>>> Hi All!
>>>>>>>
>>>>>>> After I backported all of the net80211 and iwn changes from
>>>>>>> 11-CURRENT
>>>>>>> to 10-STABLE the wireless NIC in subject working on mode G. If I try
>>>>>>> to use with mode N (ht20, ht40) it failed in association state.
>>>>>>>
>>>>>>> All of the backports are in this github repo:
>>>>>>>
>>>>>>> https://github.com/opntr/opBSD/commits/op/stable/10-iwn-backport
>>>>>>>
>>>>>>> Oliver
>>>>>>
>>>>
>>>
>>
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to