https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=202982

--- Comment #16 from robert.burmeis...@utoledo.edu ---
Bug 202982 - Installation of gnome related ports (xfce, vbox, abiword,
gnumeric) cause CONFLICT: install of python3-3_3 conflicts with python2-2_3 

To clarify:
webkit2-gtk3-2.8.5_7 depends on file: /usr/local/bin/python2.7 - found
webkit2-gtk3-2.8.5_7 depends on executable: python2 - found
iso-codes-3.69 depends on file: /usr/local/bin/python3.5 - found
iso-codes-3.69 depends on executable: python3 - not found

As of 2015-01-11 the default lang/python3 is lang/python34!

So, my attempt to install XFCE4 is trying to pull in 3 versions of python
which the make files are not handling correctly.

I will try adding DEFAULT_VERSIONS+= python3=3.5 in my /etc/make.conf.

relevant build log:
---
/!\ WARNING /!\
needs Python 3.5 at least. But a port depending on this one specified 2.7

===>  License LGPL21 accepted by the user
===>   iso-codes-3.69 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by iso-codes-3.69 for building
===>  Extracting for iso-codes-3.69
=> SHA256 Checksum OK for iso-codes-3.69.tar.xz.
===>  Patching for iso-codes-3.69
===>   iso-codes-3.69 depends on executable: msgfmt - found
===>   iso-codes-3.69 depends on executable: gmake - found
===>   iso-codes-3.69 depends on file: /usr/local/bin/python3.5 - found
===>   iso-codes-3.69 depends on executable: python3 - not found
===>   python3-2_3 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by python3-2_3 for building
===>  Extracting for python3-2_3
===>  Patching for python3-2_3
===>  Configuring for python3-2_3
===>  Staging for python3-2_3
===>   python3-2_3 depends on file: /usr/local/bin/python2.7 - found
===>   python3-2_3 depends on file: /usr/local/bin/python2.7 - found
===>   Generating temporary packing list
/bin/ln -sf python2.7 
/tmp/usr/ports/lang/python3/work/stage/usr/local/bin/python2
/bin/ln -sf 2to3-2.7 
/tmp/usr/ports/lang/python3/work/stage/usr/local/bin/2to3-2
/bin/ln -sf idle2.7  /tmp/usr/ports/lang/python3/work/stage/usr/local/bin/idle2
/bin/ln -sf pydoc2.7 
/tmp/usr/ports/lang/python3/work/stage/usr/local/bin/pydoc2
/bin/ln -sf python2.7-config 
/tmp/usr/ports/lang/python3/work/stage/usr/local/bin/python2-config
/bin/ln -sf python-2.7.pc 
/tmp/usr/ports/lang/python3/work/stage/usr/local/libdata/pkgconfig/python2.pc
====> Compressing man pages (compress-man)
===>  Installing for python3-2_3
===>  Checking if python3 already installed
===>   Registering installation for python3-2_3 as automatic
Installing python3-2_3...
pkg-static: python3-2_3 conflicts with python2-2_3 (installs files into the
same place).  Problematic file: /usr/local/bin/2to3-2
*** Error code 70

Stop.
make[14]: stopped in /usr/ports/lang/python3
*** Error code 1

---

porversion -v | grep "py"
py27-enum34-1.1.6           =  up-to-date with port 
py27-libxml2-2.9.4          =  up-to-date with port 
py27-setuptools27-28.1.0    =  up-to-date with port 
python-2.7_2,2              =  up-to-date with port 
python2-2_3                 =  up-to-date with port 
python27-2.7.12             =  up-to-date with port 
python35-3.5.2              =  up-to-date with port

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
freebsd-xfce@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"

Reply via email to