Follow-up Comment #4, bug #13810 (project freeciv):

> static inline bool setting_boolval(conct struct setting_s *op)

That should be "const" of course.

I'm also not sure about the naming scheme, since
with the full "setting_" prefix this makes it a
little awkward to use in expressions.

Perhaps just SBOOLVAL or some similar short
macro-like name (beware conflicts though, both
literal and conceptual :)).



Reply to this item at:


  Message sent via/by Gna!

Freeciv-dev mailing list

Reply via email to