At 12:09 AM 5/6/2006 +0300, dima wrote:
Game won't to run without himem and emm386 or fdxxms and umbpic, cause not
enough memory.


Okay, I stole a 48M Pentium 133Mhz laptop from the clutches of a Cro-Magnon in a passing time-rift and tried the game out on that. Under FreeDOS SETUP.EXE still doesn't work as expected, but the game does start and then give the exception you list after selecting a difficulty level.

Unfortunately, it does exactly the same thing with the MS-DOS memory managers. And the two test machines are about as different as can be, with almost nothing loaded other than a mouse driver and DOS=HIGH in common. So whatever is happening, it's happening either with FreeDOS kernel itself or the mouse driver (which is really unlikely).

Too much memory is pretty well ruled out if 48M still fails. Excluding all high memory fails with either MS-DOS or FreeDOS HIMEM+EMM386 so a bad UMB is not it either.

Have you tested this in a pure MS-DOS environment to see if it works? SETUP.EXE and the game will run here under a Windows 98 DOS box, at least to the game beginning.

(While I have this relic to test on, who was the guy who had problems with unsupported VDS and an application? Might be able to duplicate it now.)





-------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to