Shan Kumaraswamy wrote:
Rob/ Kostya,
Thanks for your quick response, as per Rob’s note I have compared the old installation and new system installation, and I find that there is a different versions of “python-cheetah” rpm, so I removed old version and installed appropriate version, now I can find the admin user as well as ipa_webgui is working properly

Glad to hear it. Do you happen to have the details on the version that works?

thanks

rob



On Fri, Jul 9, 2010 at 8:27 AM, Konstantin Kozlov <koz...@spbcas.ru <mailto:koz...@spbcas.ru>> wrote:

    As you use python 2.4 it is probably CentOS 5.

    Check if you have SPICE libs installed:
    tclspice-20-3.el5
    qspice-libs-0.3.0-39.el5_4.3
    qspice-0.3.0-39.el5_4.3
    In CentOS rpm dependencies were
    broken sometime ago when I tried to install FreeIPA.

    Best regards,

    Kostya


    On Thu, 08 Jul 2010 11:48:01 -0400
    Rob Crittenden <rcrit...@redhat.com <mailto:rcrit...@redhat.com>> wrote:

     > Shan Kumaraswamy wrote:
     > > Dear All,
     > > FreeIPA ipa_webgui not starting
     > >
     > > Please find the below error message:
     > >
     > > [r...@saprhds001 ~]# /usr/sbin/ipactl restart
     > > Shutting down ipa_webgui:                                  [FAILED]
     > > Shutting down ipa_kpasswd:                                 [  OK  ]
     > > Stopping httpd:                                            [  OK  ]
     > > Stopping Kerberos 5 KDC:                                   [  OK  ]
     > > Shutting down dirsrv:
     > >     MYDOMAIN-COM...                                        [  OK  ]
     > > Shutting down ntpd:                                        [  OK  ]
     > > Starting dirsrv:
     > >     MYDOMAIN-COM...                                        [  OK  ]
     > > Starting ntpd:                                             [  OK  ]
     > > Starting Kerberos 5 KDC:                                   [  OK  ]
     > > Starting ipa_kpasswd:                                      [  OK  ]
     > > Starting ipa_webgui:                                       [  OK  ]
     > > Starting httpd:                                            [  OK  ]
     > > [r...@saprhds001 ~]# tail -f /var/log/ipa_error.log
     > >   File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
     > > 2479, in ? working_set.require(__requires__)
     > >   File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
     > > 585, in require
     > >     needed = self.resolve(parse_requirements(requirements))
     > >   File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
     > > 483, in resolve
     > >     raise DistributionNotFound(req)  # XXX put more info here
     > >
     > > Please help me to fix this issue.
     >
     > Do you have any more context on this? Does it say anywhere what is
     > not being found?
     >
     > What is your distribution and where did you get the packages?
     >
     > We've gotten reports of people trying to build ipa in CentOS and
     > having problems like this related to python-cheetah. I've never seen
     > a resolution nor have I been able to duplicate the problem so I'm not
     > sure what the next step is, other than verifying that you have
     > python-cheetah installed.
     >
     > rob
     > >
     > > On Thu, Jul 8, 2010 at 4:43 PM, Shan Kumaraswamy
     > > <shan.sys...@gmail.com <mailto:shan.sys...@gmail.com>
    <mailto:shan.sys...@gmail.com <mailto:shan.sys...@gmail.com>>> wrote:
     > >
     > >     Dear All,
     > >
     > >     [r...@saprhds001 sbin]# kinit admin
     > >     Password for ad...@mydomain.com <mailto:ad...@mydomain.com>
    <mailto:ad...@mydomain.com <mailto:ad...@mydomain.com>>:
     > >     [r...@saprhds001 sbin]# klist
     > >     Ticket cache: FILE:/tmp/krb5cc_0
     > >     Default principal: ad...@mydomain.com
    <mailto:ad...@mydomain.com>
     > > <mailto:ad...@mydomain.com <mailto:ad...@mydomain.com>> Valid
    starting     Expires
     > > Service principal 07/08/10 16:37:47  07/09/10 16:37:43
     > >     krbtgt/BMIBANK.COM <http://bmibank.com/>@MYDOMAIN.COM
    <http://mydomain.com/>
     > > <mailto:krbtgt <mailto:krbtgt>/BMIBANK.COM
    <http://bmibank.com/>@MYDOMAIN.COM <http://mydomain.com/>>
     > >
     > >     Kerberos 4 ticket cache: /tmp/tkt0
     > >     klist: You have no tickets cached
     > >     [r...@saprhds001 sbin]# /usr/sbin/ipa-finduser admin
     > >     There was a problem importing one of the required Python
     > > modules. The error was:
     > >         No module named kerberos
     > >
     > >     And when I try to restart the ipa server, the ipa_webgui
     > > service is not shouting down and web server not working. Please
     > > advice me what went wrong?
     > >
     > >
     > >
     > >     --
     > >     Thanks & Regards
     > >     Shan Kumaraswamy
     > >
     > >
     > >
     > >
     > > --
     > > Thanks & Regards
     > > Shan Kumaraswamy
     > >
     > >
     > >
    ------------------------------------------------------------------------
     > >
     > > _______________________________________________
     > > Freeipa-users mailing list
     > > Freeipa-users@redhat.com <mailto:Freeipa-users@redhat.com>
     > > https://www.redhat.com/mailman/listinfo/freeipa-users
     >
     > _______________________________________________
     > Freeipa-users mailing list
     > Freeipa-users@redhat.com <mailto:Freeipa-users@redhat.com>
     > https://www.redhat.com/mailman/listinfo/freeipa-users

    _______________________________________________
    Freeipa-users mailing list
    Freeipa-users@redhat.com <mailto:Freeipa-users@redhat.com>
    https://www.redhat.com/mailman/listinfo/freeipa-users




--
Thanks & Regards
Shan Kumaraswamy


_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to