I used --force to delete myreplica from mymaster. And then 
runipa-replica-install on the myreplica again.
This time everything seems ok until it comes to the end:

Applying LDAP updates
Restarting the directory server
Restarting the KDC
Restarting the web server
creation of replica failed: Command '/bin/systemctl restart ipa.service' 
returned non-zero exit status 1

Your system may be partly configured.
Run /usr/sbin/ipa-server-install --uninstall to clean up.

And this is the error message at the end of /var/log/ipareplica-install.log:

2012-06-22T02:02:01Z DEBUG stderr=Job failed. See system journal and 'systemctl 
status' for details.

2012-06-22T02:02:01Z DEBUG Command '/bin/systemctl restart ipa.service' 
returned non-zero exit status 1
  File "/sbin/ipa-replica-install", line 494, in <module>

  File "/sbin/ipa-replica-install", line 488, in main

  File "/usr/lib/python2.7/site-packages/ipapython/platform/fedora16.py", line 
101, in enable

  File "/usr/lib/python2.7/site-packages/ipapython/platform/systemd.py", line 
85, in restart
    ipautil.run(["/bin/systemctl", "restart", 
self.service_instance(instance_name)], capture_output=capture_output)

  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 304, in run
    raise CalledProcessError(p.returncode, args)

Should I run ipa-server-install --uninstall on myreplica now?


> From: Rob Crittenden <rcrit...@redhat.com>
>To: george he <george_...@yahoo.com> 
>Cc: "freeipa-users@redhat.com" <freeipa-users@redhat.com> 
>Sent: Thursday, June 21, 2012 4:35 PM
>Subject: Re: [Freeipa-users] replica installation clean up
>george he wrote:
>> Hi,
>> after ipa-replica-install and ipa-replica-install --uninstall, now I get
>> [root@myreplica ~]# ipa-replica-install --setup-ca
>> /var/lib/ipa/replica-info.gpg
>> .
>> .
>> .
>> Connection check OK
>> The host myreplica already exists on the master server. Depending on
>> your configuration, you may perform the following:
>> Remove the replication agreement, if any:
>> % ipa-replica-manage del myreplica
>> Remove the host entry:
>> % ipa host-del myreplica
>> If I run this on myreplica:
>> [root@myreplica ~]# ipa-replica-manage del myreplica
>> IPA is not configured on this system.
>> [root@myreplica ~]# ipa host-del myreplica
>> ipa: ERROR: Kerberos error: ('Unspecified GSS failure. Minor code may
>> provide more information', 851968)/('Cannot find KDC for requested
>> realm', -1765328230)
>> If I un this on mymaster:
>> [root@mymaster ~]# ipa-replica-manage del myreplica
>> Unable to delete replica myreplica: {'desc': "Can't contact LDAP server"}
>> [root@mymaster ~]# ipa host-del myreplica
>> ipa: ERROR: invalid 'hostname': An IPA master host cannot be deleted or
>> disabled
>> How do I clean up the unsuccessful installation - uninstallation of a
>> replica?
>Ideally you remove the agreement before deleting the replica, hence the 
>LDAP error. Add the --force flag:
># ipa-replica-manage del myreplica.fqdn --force
>Then you should be able to delete the host entry.
Freeipa-users mailing list

Reply via email to