thanks IM trying that but running in to an issue where it says im still 
installed I run the uninstall command and I get this

root@se-idm-ubuntu-client-01:~# ipa-client-install --uninstall
Unconfigured automount client failed: [Errno 2] No such file or directory
certmonger failed to start: [Errno 2] No such file or directory: 
'/var/run/ipa/services.list'
certmonger failed to stop: [Errno 2] No such file or directory: 
'/var/run/ipa/services.list'
Disabling client Kerberos and LDAP configurations
Failed to remove krb5/LDAP configuration:

isnt there a conf file I can remove or a a way to force the uninstall?


________________________________
From: Will Sheldon [m...@willsheldon.com]
Sent: Friday, February 21, 2014 9:32 AM
To: Todd Maugh
Cc: freeipa-users@redhat.com
Subject: Re: [Freeipa-users] adding ubuntu client to red hat server


I ran into this, there was a post bout it a little while back. It seems that 
you can modify ipapython/version.py to revert the version number for enrolment, 
then revert it. with no ill effects.

 My script looks like:

#revert reported version of ipapython so keys will upload properly (backup 
first tho)
cp /usr/share/pyshared/ipapython/version.py 
/usr/share/pyshared/ipapython/version.py.bak
sed -i "s/API_VERSION=.*/API_VERSION=u'2.49'/g" 
/usr/share/pyshared/ipapython/version.py

# install!
ipa-client-install -d -U --enable-dns-updates --hostname=$FQDN --mkhomedir 
--password=$PASS

#revert change to the ipapython version back again
#rm -f /usr/share/pyshared/ipapython/version.py && mv 
/usr/share/pyshared/ipapython/version.py.bak 
/usr/share/pyshared/ipapython/version.py




Kind regards,

Will Sheldon
+1.778-689-1244


On Friday, February 21, 2014 at 9:20 AM, Todd Maugh wrote:

Hello,

 Another day another issue it seems :)

so  I'm trying to set up an ubunutu client I get almost all the way through the 
install and it fails with a version error. Ive hear this is a known bug and 
there is a fix out there. although Im not sure how to apply the fix or get the 
older client install.

my error is as follows:

Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_dsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ecdsa_key.pub
Forwarding 'host_mod' to server u'https://se-idm-01.boingo.com/ipa/xml'
host_mod: 2.58 client incompatible with 2.49 server at 
u'https://se-idm-01.boingo.com/ipa/xml'
Failed to upload host SSH public keys.


Please help

Thanks

-Todd
tma...@boingo.com<mailto:tma...@boingo.com>
_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com<mailto:Freeipa-users@redhat.com>
https://www.redhat.com/mailman/listinfo/freeipa-users

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to