> 
> web ui uses API command:
> {"method":"dnsrecord_show","params":[["my.zone.test.","LIFX\\032Bulb"],{"all":true,"rights":true,"structured":true,"version":"2.163"}]}
> 
> Could you check what is yours?
> 1. open developer tool in browser (usually F12)
> 2. Network tab
> 3. Refresh the page, look at new request to ipa/session/json
> 4. examine "Request Payload"
> some old example in FF:
> https://pvoborni.fedorapeople.org/images/devtools.png


Mine seems to show the exact same thing:

<snip>
{"method":"dnsrecord_show","params":[["casalogic.lan.","LIFX\\032Bulb"],{"all":true}]}
<snip>

My version reports {"version":"2.156"}]}

Tried FF and Chrome, but same result in both.

However:

# ipa dnsrecord-show casalogic.lan. LIFX\032Bulb
ipa: ERROR: LIFX032Bulb: DNS resource record not found
# ipa dnsrecord-show casalogic.lan. "LIFX Bulb"
ipa: ERROR: LIFX\032Bulb: DNS resource record not found

But: 
# ipa dnsrecord-find casalogic.lan
......
  Record name: LIFX\032Bulb
  A record: 192.168.20.252
  TXT record: "009143ca16c9890339c7ec33825e0da5ce"
.....

# ipa --version
VERSION: 4.2.0, API_VERSION: 2.156



> I would say that there weren't any changes in 4.2 -> 4.3 it this area.
> So not sure why the behavior in your case is opposite.
> 
> Anyway it suggests minor encoding issue.
> --
> Petr Vobornik

-- 
Med venlig hilsen 

Troels Hansen 

Systemkonsulent 

Casalogic A/S 


T (+45) 70 20 10 63 

M (+45) 22 43 71 57 

Red Hat, SUSE, VMware, Citrix, Novell, Yellowfin BI, EnterpriseDB, Sophos og 
meget mere.

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to