On 5/28/20 8:00 AM, Jim Diamond wrote:
On Wed, May 27, 2020 at 21:58 (-0500), Peter G wrote:

On 5/27/20 9:37 PM, Jim Diamond wrote:
On Wed, May 27, 2020 at 21:32 (-0500), Peter G wrote:
On 5/27/20 4:58 PM, Thomas Adam wrote:
On Wed, May 27, 2020 at 04:41:08PM -0500, peter g wrote:
Hi Everyone:
i have a frustrating issue with fvwm and casting from google's chrome, that
maybe somebody has a workaround for.
Normally, under any other WM i've tried (and also on windows), in the chrome
browser, choosing "Cast", will pop up a small window that asks the user what
device to cast to. Unfortunately in fvwm that little window with those
options does not show up.
I've tried both with my config, but also with a very fvwm config such as:
key c  A CM FvwmConsole
key r  A CM Restart
Key u  A CM Exec xterm
If anyone has a work around, that would be much appreciated, as casting, for
better or worse, is very useful to me.
Well, if it's a transient window, it will (by default) popup along side the
parent window.  That said, you can try:
BugOpts ExplainWindowPlacement On
in your ~/.fvwm2rc file, and monitor stderr to see what FVMM thinks of your
missing window.
Thanks, I've tried that.
Doesn't show anything (I know that option is working, as I get the debug
info for other windows). As pointed out in another email, that "cast" window
might indeed be a chrome internal window... what bothers me though, is why
it shows up in other window managers.
I haven't tried another window manager, but for what it's worth, the
cast window does not show up for me in google-chrome.
Thank you for checking!
No trouble!

By the way, are you running these different window managers on the
same Linux distro?  Or is it possible you are using fvwm on one Linux,
and other window managers on a different Linux distro?
I have done these check on the same machine, with the same installation of
chrome (i.e just long into a different WM).
A few window managers i checked: icewm, lxde, gnome (ubuntu's 18.04 default
desktop), ubuntu's winland desktop thing. All work as expected.
BTW, I'm running the latest github version 2 master branch of fvwm. Which
are you running?
I tried this with google-chrome-81.0.4044.113 / fvwm-2.6.6+git on
Slackware64-14.2 as well as google-chrome-83.0.4103.61 / fvwm-2.6.9 on

The 2.6.6+git is probably (memory fails, I installed it in Sept 2017)
a version from git around when 2.6.6 was the latest and greatest.

If I get a chance to try another wm on these systems I'll follow-up.

ok, thanks for that.

Per Dan Espen's recommendation i tried to load some desktop-environment thing as well as and seeing what chrome is complaining about via strace... but at no avail.



Reply via email to