Hi Nate,

thanks a lot for your hints. I was finally able to fix the problem. Galaxy 
couldn?t find the .drmerr file because our

SGE installation merged .drmerr into .drmout... now everything works fine!

Cheers,

Sascha

 

Original Message

processed by CONSOLIDATE

Subject:

Re: [galaxy-dev] Job output not returned from Cluster

Sent:

Freitag, 13. Juli 2012 19:35

From:

Nate Coraor (n...@bx.psu.edu)


On Jul 9, 2012, at 11:25 AM, Sascha Kastens wrote:

> Hi!
>  
> Unfortunately I was not able to fix this problem yet.
>  
> Is anybody out there who had a similar problem while using Galaxy with SGE or 
> has the knowledge about the things I can look at?

Hi Sascha,

The error message you are getting is because the SGE job?s stdout and stderr 
files are not where Galaxy expects to find them.  The working directory will be 
output to the debug log prior to the job?s execution and should resemble:

    //

where:

    is the absolute path to the value of job_working_directory in 
universe_wsgi.ini
    is determined based on the job ID but is most likely ?000? if you are just 
setting up a new server
    is the job?s ID as shown in the debug log

Upon job completion, this directory should contain files like .drmout and 
.drmerr.

Is it possible that your SGE installation is overriding the stdout/stderr 
paths, or that job_working_directory is not a shared filesystem?

>  
> Thanks in advance!
>  
> Cheers,
> Sascha
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>  http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to