Hi all,

I'm trying to run galaxy-central on my laptop in order to play around
with some changes, and I'm having trouble getting it to run. I can run
galaxy-dist without problems and have been working with that (so its
eggs are all installed already), but now I want to create a pull
request so want to run galaxy-dist. I'm not trying to install any
extra tools or data, just the code.

I'm running on OSX 10.7.4 and using virtualenv. I have Enthought
installed, and I assume I will be using its version of python by
default. The default python seems to be 2.7.3.

I'm using the same virtualenv environment for galaxy-dist and
galaxy-central (though it doesn't seem to matter if I give
galaxy-central its own environment, I see the same error). So the
steps were:
- create a virtualenv environment and activate it
- get galaxy-dist and call run.sh - it asked me to build quite a lot
of dependencies myself, which was just a matter of running the
requested commands, and then it worked with no problems.
- shut down galaxy-dist, and in another directory, get galaxy-central
and call run.sh. I think it asked me to build a couple of
dependencies, but then it gives up with the following:

(galaxy_env)Clares-MacBook-Pro:galaxy-central clare$ sh run.sh --reload
Some eggs are out of date, attempting to fetch...
Warning: MarkupSafe (a dependent egg of Mako) cannot be fetched
Warning: pycrypto (a dependent egg of Fabric) cannot be fetched
Warning: simplejson (a dependent egg of WebHelpers) cannot be fetched
Fetched http://eggs.g2.bx.psu.edu/ssh/ssh-1.7.14-py2.7.egg
One of Galaxy's managed eggs depends on something which is missing,
this is almost certainly a bug in the egg distribution.
Dependency "ssh" requires "pycrypto>=2.1,!=2.4"
Traceback (most recent call last):
  File "./scripts/fetch_eggs.py", line 30, in <module>
    c.resolve() # Only fetch eggs required by the config
  File "/Users/clare/galaxy/galaxy-central/lib/galaxy/eggs/__init__.py",
line 345, in resolve
  File "/Users/clare/galaxy/galaxy-central/lib/galaxy/eggs/__init__.py",
line 168, in resolve
    dists = pkg_resources.working_set.resolve( (
self.distribution.as_requirement(), ), env, self.fetch )
line 569, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (ssh 1.7.14
Fetch failed.

Any idea what is causing this?



Clare Sloggett
Research Fellow / Bioinformatician
Life Sciences Computation Centre
Victorian Life Sciences Computation Initiative
University of Melbourne, Parkville Campus
187 Grattan Street, Carlton, Melbourne
Victoria 3010, Australia
Ph: 03 903 53357          M: 0414 854 759
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to