Thanks for your reply Peter

The other tools work fine. I noticed that the makeblastdb process was still running on the server even after Galaxy said the job was complete, but still no files appeared in this directory. I have killed that process for now and will play around with it and see if I can figure it out. I'll let you kno if I find something.

Shaun

Quoting Peter Cock <p.j.a.c...@googlemail.com> on Wed, 5 Dec 2012 15:44:47 +0000:

On Wed, Dec 5, 2012 at 2:37 PM, Shaun Webb <swe...@staffmail.ed.ac.uk> wrote:

I have just installed the Blast+ tools from the Galaxy tool shed and tried
to make a Blast DB from a fasta file in history. The tool runs ok and
indicates that a blastdb has been created in:

/storage/home/galaxy/production/galaxy-dist/database/files/085/dataset_85192_files/blastdb


There should be a collection of files named blastdb.* in the folder
/storage/home/galaxy/production/galaxy-dist/database/files/085/dataset_85192_files/

However there is no directory dataset_85192_files. I have blast installed
and I'm able to run makeblastdb on the command line.

Do I have to make any other modifications before I can use Blast tools?

I'm unsure what could be wrong. Do the other BLAST+ tools seem to
work (e.g. blastp)? Are all the BLAST tools configured the same way
in terms of universe_wsgi.ini and their job runners - or do you have
some running on the cluster and some on the head node?

My guess is something about the mounted storage, but then I
would have expected problems with other tools as well.

Peter





--
The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to