On Fri, Sep 20, 2013 at 8:48 AM, Bjoern Gruening
<bjoern.gruen...@gmail.com> wrote:
> Hi,
>
> I tried to things to solve it.
>
> 1: I uploaded a new version to:
>  http://testtoolshed.g2.bx.psu.edu/view/iuc/package_atlas_3_10 this time
> with target_filename="ATLAS.tar.bz2". That is a rather new feature, so
> you will need a recent Galaxy version. The prosite is that we do not
> need to call 'tar', we are using the python tarfile module. Hopefully
> that will work, also on OS-X
>
> 2: I have created:
> http://testtoolshed.g2.bx.psu.edu/view/iuc/package_atlas_3_11
> Peter was able to install it on OS-X, at least on commandline, so I have
> hope that this one is working, well. The downside is, that it is a
> unstable version and will disappear from the server.
>
> Would be great if you can give both a try. For me its working. That
> means on ubuntu its installed and on Fedora its failing silently with
> 'It appears you have cpu throttling enabled, which makes timings
> unreliable and an ATLAS install nonsensical. Aborting. See
> ATLAS/INSTALL.txt for further information'.
>

I don't have access to my OS X box until later tonight. On Ubuntu with
an up-to-date instance of galaxy-central is failing now for me with a
different error:
STDOUT
./xconfig -d s 
/home/cborroto/src/galaxy-central/database/tmp/tmp-toolshed-mtdyWTv64/ATLAS/build/../
-d b 
/home/cborroto/src/galaxy-central/database/tmp/tmp-toolshed-mtdyWTv64/ATLAS/build
 -Fa alg -fPIC -Si lapa
ckref 1
xconfig exited with 127
#############################################

#############################################

                    mkdir build &&
                    cd build &&
                    mkdir
/home/cborroto/src/shed_tools_dependencies.central/atlas/3.10.1/iuc/package_atlas_3_10/d32504e1aea8/atlas/
&&
                    ../configure -Fa alg -fPIC
--prefix=/home/cborroto/src/shed_tools_dependencies.central/atlas/3.10.1/iuc/package_atlas_3_10/d32504e1aea8/atlas/
--with-netlib-lapack-tarfile=../lapack-3.4.2.tgz

STDERR
cat: ..//CONFIG/src/Makefile: No such file or directory
cp: cannot stat ‘..//CONFIG/src/atlcomp.txt’: No such file or directory
make: *** No rule to make target `xconfig'.  Stop.
/bin/sh: 1: ./xconfig: not found

Full INSTALLATION.log:
http://pastebin.com/raw.php?i=hvqFWvgJ

Somehow this is also a silent failing and numpy, biopython and
ngs-tools(my tool package depending on biopython) get
"Installed"(Green) while lapack, atlas and split_by_barcode(my actual
tool wrapper depending on ngs-tools package) get "Installed, missing
tool dependencies"(Grey). This means if I try to use my wrapper in
this state I get this error:
/bin/sh: 1: ngs-tools: not found

However, if I do a "Repair repository" on split_by_barcode it goes
into "Installed"(Green) and everything seems to work from then on.

Thanks for working on this,
Carlos

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to