Hello again,


I cannot launch it manually neither. It gives me the same error… :


>runWolfPsortSummary animal test.fasta


>Can't locate fastafmt/GetOptWarnHandler.pm in @INC (you may need to install 
>the fastafmt::GetOptWarnHandler module) (@INC contains: /etc/perl 
>/usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 
>/usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 
>/usr/local/lib/site_perl . /bin) at /bin/runWolfPsortSummary line 37.

BEGIN failed--compilation aborted at /bin/runWolfPsortSummary line 37.


I think i missed something somewhere. Any lead?




De : Peter Cock [mailto:p.j.a.c...@googlemail.com] 
Envoyé : mercredi 2 décembre 2015 18:59
À : Olivier CLAUDE <o.cla...@outlook.fr>
Cc : galaxy-dev@lists.galaxyproject.org; Björn Grüning 
Objet : Re: [galaxy-dev] 3 questions


On Wed, Dec 2, 2015 at 5:07 PM, Olivier CLAUDE < <mailto:o.cla...@outlook.fr> 
o.cla...@outlook.fr> wrote:

Hello again,



I managed to find WolfPsort on github.


You mean  <https://github.com/fmaguire/WoLFPSort> 
https://github.com/fmaguire/WoLFPSort ? I can see why Finlay Maguire did that 
although I'm not 100% sure that is within the licence.

In other news, it looks like someone else has bought the domain  
<http://wolfpsort.org/> http://wolfpsort.org/ and is holding it to random (for 
sale, offers over $1190). Oh dear. :(


I followed the readme file and it work with the command line but when I tried 
to run it on galaxy with the one included in the package “tmhmm and signal” 
from peterjc, it gave me an error:


“can’t locate fastafmt/GetOptWarnHandler.pm”


I put in my .bashrc the path of the file. I tried to put it directly in the 
/bin directory but it didn’t change anything.

Any idea anyone?


Have you followed the INSTALL file instructions? Have you been able to run 
WolfPsort at the command line?

Note it only has precompiled binaries under bin/binByPlatform for i386 and 
sparc, however we could use the 32bit binaries on our 64bit Linux machine.


According to my old comment inside the Python wrapper script for Galaxy, I had 
trouble running the tool from outside its home directory and so used a simple 
(second) wrapper script to change directory before running the real binary. See:





2/in the python script I can see:


                Num_thread = thread_count(sys.argv[2], default=4)


Does it means that it will use at the maximum 4 threads? Can I assume it will 
use 4 core in parallel? 




This means my Python wrapper script will default to 4 threads if not specified 
via the command line.

When called via Galaxy, the XML wrapper will use the $GALAXY_SLOTS environment 
variable (if set). See the job runner settings taken from job_conf.xml for 

This means unless you've setup something special in Galaxy for the number of 
slots/threads to use, the tool will default to four threads. This means it will 
break up the input file into chunks and run four copies of the single threaded 
tool runWolfPsortSummary at once.


3/I use blast + from the devteam is there any possibility to use more than 1 
core? If yes where? 



Thanks !


Again, the BLAST+ wrappers will use the $GALAXY_SLOTS environment variable (if 
set), although here they default to using calling BLAST+ with 8 threads. 



Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to