One other thing forgot to mention - again hyping on about edSharp for python coding...<smile> - is that it has keystrokes to jump to next code block, next indentation change/level, and in code like PHP, etc. it can jump to starting/ending/matching braces, etc., but anyway.

Stay well

Jacob Kruger
Blind Biker
Skype: BlindZA
'...fate had broken his body, but not his spirit...'

----- Original Message ----- From: "Thomas Ward" <thomasward1...@gmail.com>
To: "Gamers Discussion list" <gamers@audyssey.org>
Sent: Saturday, February 18, 2012 7:53 PM
Subject: Re: [Audyssey] Python and Interactive Fiction


Hi Jacob,

Oh, yeah. So do I. Not only was it the way I was taught to program
those conventions you mention at least have use to me on a day to day
basis. Declaring an integer variable as iSumNumber or a string as
sMyString helps me keep the variables and data types straight.
Especially, in Python which doesn't need an explicit declaration of
the data type. Variables just pop into existence with whatever kind of
data you assign it which can get confusing, for me at least, in
figuring out if I assigned an integer, float, etc to that variable.

Also I've gotten in the habit of closing my blocks of code with
comments as well. Since if statements, functions, loops, etc in Python
have no closing braces etc I add a comment like #End if, #End loop, or
#End function so I can quickly determine where one block ends and
another one begins etc. While not necessary I do find it useful for my
own programming needs.

Cheers!


On 2/17/12, Jacob Kruger <jac...@mailzone.co.za> wrote:
Will also just bring up that, aside from formatting, commenting has always
been a good thing, for sighted guys, VI developers, for sharing code, for
own reviewing later on, etc. etc.

What I standardly do now, at the very least is add comments to the end of
code blocks, like if statements, loops, class definitions, function
definitions, etc. etc., so that at the very least, when reviewing code later
on, I know what I'm looking at, at the end of code blocks..<smile>

Oh yes, and have always, even in sighted days used descriptive names for
variables, data structure, etc. - you don't want to be reviewing T-SQL, and
wonder what type of object/item Customers is, when it could be something
like tblCustomers, qryCustomers, qryDelCustomer, qryInsertCustomers, etc.
etc., and for variable names in code itself, things like dDate1, sString1, fFloat1, lList1, dcDictionary1, etc. are the types of naming conventions I
make use of for variable names.

Stay well

Jacob Kruger
Blind Biker
Skype: BlindZA
'...fate had broken his body, but not his spirit...'


---
Gamers mailing list __ Gamers@audyssey.org
If you want to leave the list, send E-mail to gamers-unsubscr...@audyssey.org.
You can make changes or update your subscription via the web, at
http://mail.audyssey.org/mailman/listinfo/gamers_audyssey.org.
All messages are archived and can be searched and read at
http://www.mail-archive.com/gamers@audyssey.org.
If you have any questions or concerns regarding the management of the list, please send E-mail to gamers-ow...@audyssey.org.


---
Gamers mailing list __ Gamers@audyssey.org
If you want to leave the list, send E-mail to gamers-unsubscr...@audyssey.org.
You can make changes or update your subscription via the web, at
http://mail.audyssey.org/mailman/listinfo/gamers_audyssey.org.
All messages are archived and can be searched and read at
http://www.mail-archive.com/gamers@audyssey.org.
If you have any questions or concerns regarding the management of the list,
please send E-mail to gamers-ow...@audyssey.org.

Reply via email to