Excerpts from Mike Frysinger's message of Wed Oct 13 23:46:43 +0200 2010:
> On Wednesday, October 13, 2010 15:57:17 Amadeusz Żołnowski wrote:
> > And why putting different tasks into one function?
> 
> for the same reason we dont have separate test binaries: test_exist, 
> test_file, test_dir, etc...
> 
> it makes more sense in my mind to combine the functionality.
> -mike

So the only argument for having more complicated, less intuitive and
less readable function is the old 'test' program?  Please, reconsider my
solution with more reason.  Moreover we're using 'test' as '[[ … ]]'
which changes much in readability.  Next thing is that '-a' and '-o'
don't strictly conform to 'test' convention.
-- 
Amadeusz Żołnowski

PGP key fpr: C700 CEDE 0C18 212E 49DA  4653 F013 4531 E1DB FAB5

Attachment: signature.asc
Description: PGP signature

Reply via email to