On Wednesday, October 13, 2010 18:13:18 Amadeusz Żołnowski wrote: > Excerpts from Mike Frysinger's message of Wed Oct 13 23:46:43 +0200 2010: > > On Wednesday, October 13, 2010 15:57:17 Amadeusz Żołnowski wrote: > > > And why putting different tasks into one function? > > > > for the same reason we dont have separate test binaries: test_exist, > > test_file, test_dir, etc... > > > > it makes more sense in my mind to combine the functionality. > > So the only argument for having more complicated, less intuitive and > less readable function is the old 'test' program? Please, reconsider my > solution with more reason.
we prioritize differently. i prefer unified code with options. you preferred unrolled duplicated code. > Moreover we're using 'test' as '[[ … ]]' which changes much in readability. what are you talking about ? no one is using `test` in their code and if they are, their code is broken. none of the stuff ive posted is running `test`. -mike
signature.asc
Description: This is a digitally signed message part.
