On Tue, 30 May 2017 10:05:41 +0200 Ulrich Mueller <[email protected]> wrote:
> >>>>> On Tue, 30 May 2017, Alexis Ballier wrote: > > > On Tue, 30 May 2017 00:01:16 +0200 > > Ulrich Mueller <[email protected]> wrote: > > >> Also, can we find a better name? Sorry for the bikeshedding at this > >> early stage, but I believe that ENFORCED_USE can be easily confused > >> with use.force in profiles. MAPPED_USE? USE_MAP? > > > Why do we even need a new name ? > > This was under the assumption that we would somewhat restrict the > syntax. > > Sure, if someone comes up with an algorithm that will give a unique > and predictable solution with current REQUIRED_USE syntax then we can > keep the old name. Even if restricting the syntax I'm not sure it is desirable either: If we keep current REQUIRED_USE we'll still have cases where it'll fail horribly, hence not fixing the issue. If all you care about is the syntax, then sure it is doable, but the semantics have to change, and I don't see much difference in restricting the syntax vs. changing its meaning.
