Am Tue, 20 Sep 2016 21:03:23 -0700
schrieb Daniel Frey <djqf...@gmail.com>:

> On 09/20/2016 08:26 PM, Kai Krakow wrote:
> >>
> >> I've noticed a couple more things. One is after resume from standby
> >> the plasma taskbar hangs at 100% cpu for 2-3 minutes, during which
> >> time you can't open the K menu, click on open programs in the task
> >> bar or start any apps. The tray icons and clock are also frozen.
> >> Has anyone experienced this? It only does this after resume, it
> >> seems to be fine otherwise.  
> > 
> > Any chances you're using calendar access in plasma widgets? I'm
> > using calendars via akonadi-ews, and the clock widget has access to
> > this (also korgac integrates with the plasma bars and accesses the
> > calendar). This leads plasma to blocking for about 1 minute after
> > login or resume - but only due to heavy writes of logs about
> > zoneinfo that cannot be found. The problem here is that Outlook
> > uses very strange time zone names (which even seem to change from
> > version to version, I wonder how MS programmers keep track of it).
> > The solution was to simply symlink the missing names (which you can
> > extract from the X session logs and/or journal)
> > to /usr/share/zoneinfo/localtime and now it works and my calendar
> > events are even at the correct hour (and not shifted to another
> > time zone). For me, blocking of plasma is now gone or at least
> > reduced to a very short time.  
> 
> Well, I think I might have solved this one for now. I was using the
> nouveau driver and I was playing a news clip and had no sound and
> when I clicked on the volume control in the tray my computer
> hardlocked.
> 
> I was able to ssh in to see that nouveau was crashing constantly
> trying to do what plasma was asking of it; I have installed the
> recommended nvidia-drivers version that was mentioned on nvidia's
> site and now it seems to be okay.
> 
> Six or so months ago I tried both nouveau and nvidia's drivers and
> they were both crashing plasma every 10-20 seconds.

Strange, I never had this and use plasma since 5.2 or something...
Always with the proprietary driver (as I also like to play Steam games).

> >> Is there a way to speed up alt-tab switching? Often I hit alt-tab
> >> expecting it to switch to another app but nothing happens. I have
> >> to hit it two or sometimes even three (!) times to make it switch.
> >> This is really irritating and slows down my work flow.  
> > 
> > I wonder about this annoying bug, too. As a programmer this is
> > absolutely irritating as I do a lot of alt+tab between editors,
> > logs, web browsers, and documentation. :-(
> > 
> > Something similar happens when switching tasks using the mouse:
> > Sometimes the first click on a taskbar icon is simply not fully
> > recognized, it just switches focus to plasma but doesn't switch the
> > application to front.
> > 
> > Sometimes I feel like this may be related to having multiple
> > monitors connected.  
> 
> I do not have multiple monitors. I haven't seen the mouse issue yet as
> when alt+tab isn't working I have to resort to the dang mouse and it
> always works.

Well, I use multi monitor on all setups. Here at home, I use TV and
monitor in clone mode. Mouse switching works almost reliably here
(only rarely exposing the bug). At work I use two monitors side by side,
with a desktop across both screens (no clone mode). Only there, I'm
experiencing the mouse problem often, on the other hand my home system
is much more capable. It might well be an issue related to
performance of the system.

On the other hand, when using the activity switcher (not the meta+q one
but the one that works like alt+tab, I've set it to meta+tab), it is
displayed twice - it seems once for each monitor. At work, it is shown
on both monitors. It is shown only once as soon as I disable one
monitor. I've filed a bug report for it. I think multi monitor is not
really tested well.

https://bugs.kde.org/show_bug.cgi?id=368870

> However, on the plus side, I disabled the compositor effects on the
> alt-tab switching and so now it works as expected.
> 
> I've attached a small screenshot, make sure what I've circled in red
> is NOT checked. It's under system settings -> window management ->
> task switcher.

Tried that. Didn't work at all at first, the current window was just
flashing on alt+tab. Only after manually switching with the mouse, the
keyboard shortcut worked reliably. That makes me think the root cause
is to be searched somewhere else and not really related to the
compositor effect.

Anyway, I switched back to the both checkboxes reversed. I prefer that
setup much better. I don't like alt+tab hovering the windows, and
without the compositor effect that setting disabled makes the hole
experience quite useless.


-- 
Regards,
Kai

Replies to list-only preferred.


Reply via email to