0-rro <[EMAIL PROTECTED]> writes:

> Actually I already tried to use gimptool and I did
> not succeed, even though I think I do it the way 
> it is explained in it's manpage.
> I try to uninstall and then install back plugin "rotate".
> (Just I think if I will be able to do it I will be able
> to install other plugins as well). I do it like that:
> As root:
> # gimptool --uninstall-admin-bin blur

now you are starting to confuse me: do we talk about
"blur" or "rotate" ? Also do I assume correctly that you
are only using those core plug-ins to explore gimptool?

> # gimptool --install-admin-bin blur
> Everything seems to work fine (computer does not
> report any error). I take a look at the
> /usr/local/lib/gimp/1.2/plug-ins/ and I can see file 
> "rotate" is back there. But then when I start GIMP 
> I still can not rotate (it still is not in the menu).

you should check that you are calling gimptool on the 
correct file. "--install-admin-bin" expects a binary
file as argument. Assuming you tried this in the
plug-ins/common directory of the gimp source tree, you
installed a libtool wrapper for rotate, not the plug-in
binary (the binary is in plug-ins/common/.libs). That's 
why you see the file in the plug-ins dir, but can't use 

>  I also tried to do:
> # gimptool --install-admin blur.c
> but still no result.

this on the other hand should work (after replacing blur.c
with rotate.c). 

You should notice that gimptool is only a helper tool to 
ease compilation and installation of simple plug-ins. It is
not intended to be used from within the gimp source tree
(we have some sophisticated Makefiles there and use libtool)
and it will not help you as soon as your plug-ins grows and
you decide that one source file is not enough. I suggest you 
make yourself familiar with gcc and make and have a look 
into automake, autoconf, libtool, etc. later.

Salut, Sven

Gimp-developer mailing list

Reply via email to