Hello,

thanks for the feedback but other python plugins did work like Pylomo
http://registry.gimp.org/plugin?id=10976
which didn't has a header starting with #!/usr/bin/python .

I'm using Ubuntu 7.10 and Gimpo 2.42
( http://www.getdeb.net/app.php?name=Gimp ). 

-  
 |\/\/\/|
 |      |
 | (O)(O)        Bart.
 C      _)       [EMAIL PROTECTED]
 |   ,_/
 |   /    - Ich bin nicht berechtigt Aushilfslehrer zu feuern -
 /   \
                  http://www.neeneenee.de


Am Mittwoch, den 05.12.2007, 10:14 +1100 schrieb Owen:

> On Tue, 04 Dec 2007 21:24:56 +0100
> "Eckhard M." J├Ąger <[EMAIL PROTECTED]> wrote:
> 
> > Hello,
> > 
> > i started writing the internal Gimp script for looping over the images.
> > My code is so far the simple:
> > 
> > # -*- coding: utf-8 -*-
> > 
> > from gimpfu import *
> > import os
> > import os.path
> > 
> > def python_thumbnailer(this_image, this_path):
> >     a = this_path
> > 
> > register(
> >     "python-fu-thumbnailer",
> >     "Generating thumbnails",
> >     "Generating thumbnails for Nautilus via Gimp",
> >     "Eckhard M. Jaeger",
> >     "Eckhard M. Jaeger",
> >     "2007",
> >     "<Toolbox>/Xtns/Nautilus Thumbnailer...",
> >     "",
> >     [
> >             (PF_STRING, "this_path", "Directory Path", ""),
> >     ],
> >     [],
> >     python_thumbnailer)
> > 
> > main()
> > 
> > this script is copied into ~/.gimp-2.4/plug-ins but didn't appear
> > anywhere :(
> > I can't find the bug, please can somebody help me. Thanx.
> 
> 
> 
> I don't know, but did you get any error messages when you started the Gimp 
> from the command line?
> 
> If it uses python, do you need to call python #!/usr/bin/python?
> 
> Does it have the right permissions?
> 
> When I add those corrections, I get the menu item
> 
> 
> 
> 
> 
> Owen
> 
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to