On Fri, 2008-09-19 at 20:09 -0700, bgw wrote:

> checking pkg-config is at least version 0.9.0... yes
> checking for BABL... configure: error: Package requirements (babl >= 
> 0.0.22) were not met:
> No package 'babl' found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> </quote>
> Given the standard library structure above, why doesn't gegl autogen 
> find babl?

You need to do

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/

You also need:
export LD_LIBRARY_PATH=/usr/local/lib

You will also need to do this when running your copy of gimp.
To remind me, I have a shell script, lgimp, that runs the local
gimp with:

#! /bin/sh

# export MALLOC_CHECK_=1 
exec /usr/local/bin/gimp-2.5 "$@"

you probably don't need the GEGL_NO_NODE_CACHES or BABL_ERROR settings,
though, so you could use,

#! /bin/sh

LD_LIBRARY_PATH=/usr/local/lib exec /usr/local/bin/gimp-2.5 "$@"

A simpler alternative is to put gimp in a place like $HOME/gimp where
it won't conflict with any installed version of gimp.


Liam Quin - XML Activity Lead, W3C, http://www.w3.org/People/Quin/
Pictures from old books: http://fromoldbooks.org/
Ankh: irc.sorcery.net irc.gnome.org www.advogato.org

Gimp-developer mailing list

Reply via email to