i am trying to cross compile gegl-0.0.22 with command CC=arm-linux-gcc 
./configure arm-linux --target=arm-linux --with-shared --prefix=/usr. I am 
getting below mentioned error. what is this error exactly 
configure: WARNING: you should use --build, --host, --target
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for arm-linux-gcc... arm-linux-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C 
compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

i changed 
if test "$cross_compiling" = maybe; then
if test "$cross_compiling" != maybe; then

then i got below mentioned error

checking for GTK... yes
checking for bind_textdomain_codeset... no
configure: error:
*** Check for bind_textdomain_codeset() failed!  This is required.


----- Original Message ----
From: Daniel Hornung <daniel.horn...@gmx.de>
To: gimp-developer@lists.xcf.berkeley.edu
Sent: Tuesday, 20 January, 2009 5:16:13 PM
Subject: Re: [Gimp-developer] Gimp2.6.4 for ARM processor

On Tuesday 20 January 2009, sanju More wrote:
> Hi,
> Thanks for your input. i downloaded gimp2.6.4, i configured this with some
> packages like(babl,gegl,glib....) and i did make and make install on fedora
> 10 host machine. This is working fine.
> But i need gimp2.6.4 to be cross compiled with arm-linux-gcc. For this i
> need to cross compile all these packages(babl,gegl,glib...) and then
> gimp2.6.4 or just i need compile gimp2.6.4
> -- Sanjeev

You'll need to have all the dependencies available on the other platform as 
well, which probably means you'll have to cross-compile them.


Gimp-developer mailing list

Reply via email to