On Thu, Feb 03, 2000 at 06:56:17PM +0100, Marc Lehmann wrote:
> On Wed, Feb 02, 2000 at 06:33:10PM -0500, Tom Rathborne <[EMAIL PROTECTED]> wrote:
> > >    elf_i386
> > >    elf32ppclinux
> > >    elf64alpha
> > 
> > Woo, how thorough of you.
> It's sometimes handy to have a cross-compiler for alpha. But I do
> not have a ppc machinea (I planned to, though), so it's a bit of
> overkill...
> > All I can think of is that my install/deinstall of the binutils
> > RPM fixed something... perhaps I had an ld symlink in the wrong
> > place.
> It occurs to me that this "rpm thingy" people talk so much about is
> responsible for the vast majroity of "unexplainable" bugs. Just
> yesterday I tried all sorts of precompiled apaches (including the
> redhat one), and they all dumped core. As always, building from
> source and it suddenly worked...

I agree, but in this case, as someone pointed out to me, I think it
was the lack of a 'cc->gcc' symlink in my pgcc bin directory.

> > I'm not sure why it just started working, but I will be sure to
> > look a little closer and give a more thorough bug report if it
> > happens again.
> Most probable causes for this is that the compiler has problems
> creating executables. Since environemntvariables influence
> config.guess a lot, thats the place to start looking. Of course, a
> missing ldconfig would explain it just as well.

Yes, that's a good point. I suppose setting 'CC=gcc' would have
fixed it too.



--    Tom Rathborne    [EMAIL PROTECTED]
--    "I seem to be having tremendous difficulty with my life-style."

Reply via email to