While, in theory, I agree that having compatibility cruft inside a
software package is bad, I think breaking compatibility deep within a
feature freeze was a very bad idea.

I thought different this afternoon when I could just enable
GIMP_COMPAT_CRUFT_STH, but it just turned out that this define only
catches very few of the API changes.

So, in effect, the recent undiscussed changes completely break the API and
make it impossible to maintain a plug-in for both 1.0 and 1.2 versions.

This I consider a very very bad move so close before a release, and so
deep after the feature freeze was declared.

Usually, you do something like that just after starting a new development
track, not shortly before a release.

Just my 0.00 cents.

      -----==-                                             |
      ----==-- _                                           |
      ---==---(_)__  __ ____  __       Marc Lehmann      +--
      --==---/ / _ \/ // /\ \/ /       [EMAIL PROTECTED] |e|
      -=====/_/_//_/\_,_/ /_/\_\       XX11-RIPE         --+
    The choice of a GNU generation                       |

Reply via email to