Thank you for sharing your knowledge. Yesterday I built on Debian Wheezy, too, but not into the system directories (/usr/bin etc.), but to local directories under my non-privileged users $HOME. I downloaded all dependencies (also the optional), built BABL and GEGL and tried building GIMP. GIMPs autogen ends with no errors. But GIMPs make fails in the 'cursors' directory:

Making all in cursors
make[2]: Entering directory `/home/gimpdev/Workspace/gimp/cursors'
  GEN    tool-cursors.list
  GEN    gimp-tool-cursors.h
failed to load "./cursor-bad.png": Couldn't recognize the image file format for file './cursor-bad.png'
make[2]: *** [gimp-tool-cursors.h] Error 1
make[2]: Leaving directory `/home/gimpdev/Workspace/gimp/cursors'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gimpdev/Workspace/gimp'
make: *** [all] Error 2

I found out, that downloading the latest stable GLib (2.34.3) and GDK-Pixbuf (2.26.10) and building them from sources into my $INSTALL_PREFIX solved it.

However, I don't understand why this doesn't work out of the box with the GLIb and GDK-Pixbuf packages from the distro. A bit of research led me to refreshing the GDK-Pixbuf cache (file loaders.cache somewhere under /usr/lib). Nevertheless building the cursors directory succeeds only when building as root, but fails for normal users. As I saw such effects have been an issue for years in various GTK based products and with various filetypes. Does anybody have some ideas how we can have them working and not breaking the GIMP build out of the box?

Thanks and kind regards,


gimp-user-list mailing list

Reply via email to