Quoting Nick Wilson <[EMAIL PROTECTED]>:

> * and then Dave Neary declared....
> > rpm -qa | grep gtk
> > 
> > will tell you what rpms with gtk in the name you have installed, and their
> > versions (you should have gtk+ in there, and it should be version 2.2.2 or
> > later, ideally). After that, you should check if you see a gtk+-devel
> package (a
> > similar search for glib and glib-devel could be helpful too).
> gtk+-1.2.10-25
> gtk+-devel-1.2.10-25
> ...and for glib:
> glib-1.2.10-10
> glib-devel-1.2.10-10

These versions of gtk+ and glib is too old. 

> gtk2-2.2.1-4

Weird. You have a recent version of gtk+ installed, which implies the newer
version of glib (unless you're a naughty boy and install everything -f). But you
don't. In any case, you don't have gtk2-devel installed. And you should consider
upgrading to 2.2.2 if you use any XInput devices.

> and the last few lines for the ./configure output:
> checking for pkg-config... /usr/bin/pkg-config
> checking for GLIB - version >= 2.2.0... no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link. See the file config.log for
> the
> *** exact error that occured. This usually means GLIB is incorrectly
> installed.

Your exact error is likely to be "glib-2.0.pc not found". You really need to
make sure that you search for and install the RedHat devel RPMs for gtk+ 2.2.

> heh! How odd. The first mail I got from you ended up straight in my
> inbox rather than the gimp mailbox so I figured you wanted the
> discussion off-list for some reason! ;-) - List now cc'd....

It just means that I did a Reply-all, which probably didn't trigger procmail (or
perhaps I forgot). Anyway, the list is good :)


Dave Neary
Lyon, France
Gimp-user mailing list

Reply via email to