Sven Neumann wrote:


Jogchum Reitsma <[EMAIL PROTECTED]> writes:

I did a ./configure on the gimp-2.2 source (not the CVS-line), and it
complained about not finding the TIFF-library. So I downloaded that
(v. 3.70), compiled and installed it (the libraries install in
/usr/local/lib) and ran ldconfig.

Still ./configure doesn't find it.

What am I doing wrong?

You forgot to read INSTALL, in particular the section that is titled "When ./configure fails on plug-ins".



Thanks for your quick reply.

Frankly, I did read INSTALL, and also that section, but didn't think the solution offered there would bring me luck.

But after your reply I did

export LDFLAGS="-L/usr/local/lib"

before running configure.

This is what configure says:

checking for TIFFReadScanline in -ltiff... no
checking for TIFFWriteScanline in -ltiff... no
checking for TIFFFlushData in -ltiff34... no
configure: WARNING: *** TIFF plug-in will not be built (TIFF library not found) ***
configure: error:
*** Checks for TIFF libary failed. You can build without it by passing
*** --without-libtiff to configure but you won't be able to use TIFFs then.

There are no more references to libtiff in the output from configure, as far as I can see.

Maybe I installed the wrong version of libtiff? Mine is 3.7.0: /usr/local/lib reads among other:

lrwxrwxrwx   1 root root     13 2004-11-26 14:46 libtiff -> libtiff.3.7.0*
lrwxrwxrwx   1 root root     13 2004-11-26 14:46 libtiff.3 -> libtiff.3.7.0*
-rwxr-xr-x   1 root root 700919 2004-11-26 14:46 libtiff.3.7.0*
-rw-r--r--   1 root root 981630 2004-11-26 14:46 libtiff.a
-rwxr-xr-x   1 root root    783 2004-11-26 14:46*

I don't need the tiff-library myself, so I could give --without-libtiff to configure. But since testing is my object, it would be nice to have it included.

Thanks, Jogchum

Gimp-user mailing list

Reply via email to